Some API calls returning 500 errors
Incident Report for Cheddar
Resolved
This incident has been resolved, and the API is functioning normally.

Our findings suggest that impact from this incident was minimal. Although Cheddar was returning 500 errors for API calls during the incident window, the application was still properly recording data in the platform (e.g. if a customer create call returned a 500, the customer was still created in your Cheddar product account).

We’ve implemented fixes that resolve the underlying issues and correct Cheddar’s API responses, but if you have any concerns about specific updates made during that time, please contact us at team@getcheddar.com.
Posted Jun 01, 2018 - 13:06 EDT
Monitoring
We identified a database issue that was causing 500 error responses from Cheddar on some API calls and released a fix. The issue should be resolved as of 10:08 EDT. Customers shouldn't be receiving 500 errors at this point. We'll continue to monitor the situation for the next few hours.
Posted Jun 01, 2018 - 10:46 EDT
Investigating
API calls are returning 500 errors for some customers. We’re investigating the cause and will provide an update as soon as possible.
Posted Jun 01, 2018 - 09:26 EDT
This incident affected: API.